Wetterseite unsicher oder sicher

  • Hallo,

    seit einiger Zeit habe ich ein Problem mit den Sicherheitseinstellungen für meine Wetter-Website " http://www.mi-schu.de ".
    Ich verwende den Opera-Browser, aber das Problem tritt auch bei anderen Browsern, z.B. MS Edge, auf.

    Wenn ich die Website aufrufe, erscheint oben neben der Adressleiste das Schloss-Symbol und der Hinweis: "Seite ist sicher".
    Aber dann werden nicht alle Inhalte der Website, wie z.B. das AWEKAS- oder WetterOnline-Inlet, angezeigt.
    Wenn ich dann in der Adressleiste vor "www.mi-schu.de" ein "http://" setze, werden wieder alle Inhalte korrekt angezeigt,
    und das Schloss-Symbol wird durch "nicht sicher" ersetzt.

    In den Browser-Einstellungen habe ich unter "Datenschutz und Sicherheit" und "Sicherheit" die Optionen
    "Schütze mich vor bösartigen Websites" und "Immer sichere Verbindungen verwenden" ausgeschaltet.
    Trotzdem wird die Wetterseite weiterhin als "Seite ist sicher" und unvollständig angezeigt.


    Weiss jemand, wie ich es erreichen kann, dass meine Website immer als "nicht sicher" behandelt wird?
    Am link für meine Wetterseite kann es nicht liegen, denn die wird mit "http://www.mi-schu.de" aufgerufen.


    Danke, und mit bestem Gruss
    mischu

  • Nach meiner Erfahrung unterbinden die Browser zunehmend das Mischen von verschlüsselten (HTTPS) und unverschlüsselten (HTTP) Inhalten. Wenn man also seine Website verschlüsselt mit HTTPS aufrufen möchte, dann müssen auch alle Aufrufe innerhalb der Website (Bilder, iframes etc.) mit HTTPS eingebunden sein. Im vorliegenden Fall wäre also die Einbindung des AWEKAS- und WetterOnline-Inlets auf HTTPS umzustellen.

  • Hi!


    Bei einem Aufruf einer Seite per https muessen saemtliche Bestandteile der Seite ebenfalls per https angesprochen werden. Du bindest jedoch unsichere Seiten (iframes bzw. Bilder (img) in Deiner Homepage ein, daher werden Dir die entsprechenden Bestandteile bei einem Aufruf Deiner Seite mit https nicht angezeigt.

    Wenn Du also Deine Seite per https mit https://www.mi-schu.de/ aufrufst, fehlen saemtliche Inhalte (etwa Bilder von fremden Seiten), die Du auf dieser Seite mit http referenziert hast.

    Rufst Du Deine Seite jedoch explizit mit http auf: http://www.mi-schu.de/, sollten alle Bestandteile (sofern erreichbar) angezeigt werden.


    Also:

    Immer nur mit http://www.mi-schu.de/ aufrufen - Problem (vermeintlich) geloest.


    Aber:

    Moderne Browser versuchen offenbar zunehmend, erst eine angeforderte Seite per https aufzurufen. Wenn das klappt, wird Dir stattdessen die Seite ueber dieses Protokoll angezeigt.

    Du hast jetzt 2 Moeglichkeiten:

    1. https auf dem Webserver deaktivieren (nicht empfohlen)

    Dann kann ein Browser nicht mehr die Seiten per https holen und MUSS http nutzen.

    Das sollte (vorerst) klappen. Bis evtl. Browser den Zugriff zu ungesicherten Seiten irgendwann vielleicht gar nicht mehr erlauben ...


    2. stelle die internen Verknuepfungen auf https um

    Dann sollte es egal sein, mit welchem Protokoll ein Browser versucht, auf Deine Seite zuzugreifen.

    Dazu musst Du in Deinem Quelltext der Seite nach Inhalten suchen, die bei Dir mit http:// aufgerufen werden. Aendere diese Aufrufe in https:// und das entsprechende Element sollte dann sowohl bei http- als auch bei https-Zugriff angezeigt werden.


    Das betrifft auf Deiner Startseite aktuell wohl folgende "Fremd"-Bilder und iframes:


    http://c.andyhoppe.com/1469386463

    http://www.mi-schu.de/Vantage/Weatherlink/aktuell/minidisplay.gif

    http://www.dwd.de/DWD/wetter/sat/bilder/meteosat/satbild_hrvir_akt.png

    http://st.wetteronline.de/img/logo/wetteronline_blue_114x22.png?v=1.0.637

    WetterOnline WetterWidget

    Homepagewetter


    Einfach bei all diesen Ressourcen statt des http ein https angeben - ich habe die Verfuegbarkeit per https der hinterlegten Inhalte geprueft.


    Oliver