Fehlerhafte Niederschlagsberechnung Bresser 7in1 TFT

  • Ich weiß nicht, ob er Fehler an der Station liegt oder in der Datenverarbeitung durch Awekas selbst, aber ich habe einem Bug bei der Errechnung der Tagessumme des Niederschlags bei mir entdeckt.


    Gestern (16.6) musste ich die Basistation mehrmals neu starten. Danach zeigte sie mir, wie das bis jetzt immer der Fall war, als Wert für den aktuellen Niederschlag seit Mitternacht den Wert 0 an, obwohl schon ettliche mm Niederschlag an dem Tag angefallen sind.


    Nach dem letzten Hochfahren regnete es noch 9,1 mm. Dieser Wert geht nun als Tageswert in die Gesamtstatistik ein, obwohl an dem Tag in Summe gut über 20 mm gefallen waren.


    Die Monatsgrafik hat den Wert von 9.1 mm und die Wertetabelle weißt in der Zeile max., in der normal die Gesamtsumme des Niederschlags den selben Wert stehen.


    Zählt man aber die Stundenwerte zusammen, so kommt man auf die tatsächlich gefallene Menge vom 20.3 mm.


    Im der Gesamtstatistik fehlen nun 11,2 mm.

    Rechnet da Awekas tatsächlich falsch. Kann man der Gesamtstatistik vertrauen, oder kommen jedesmal, wenn man mal die Basisstation umstellt oder einen Neustart braucht, falsche Werte in die Berechnung?


    Liegt es daran, dass Awekas die Tagesummen nich selbst rechnet, sondern übernimmt, was meine "vergessliche" Station sendet?

  • Weitere Erkenntnisse aus der Sache:


    Gestern (17.9) konnte ich den Fehler nicht reproduzieren. Ich habe die Station vom Strom getrennt und die bisher angefallenen Messwerte für den Niederschlag gingen auf der Station verloren.


    Awekas hatte aber die Werte gespeichert und rechnete auch alles richtig.


    Wäre der Fehler erneut aufgetreten, so hätte die Gesamtregenmenge 0,2 mm betragen, also den Wert, der nach dem Wiedereinschalten gemessen wurde.


    Die falschen Werte vom 16.9 (9.1 statt 20.3 mm) blieben aber stehen. Hier hatte ich die Hoffnung, dass es zu einer Neuberechnung der Tagessumme kommt, wenn der ganze Tag aus der 24 Stunden Berechnung draußen ist.


    Kann sich das jemand erklären? Soll ich nun den Tageswert manuell editieren, oder besteht die Gefahr, dass im Zuge einer Berechnung eines Monats- oder Jahreswertes dann Fehler entstehen?


    LG Gue

    ID 24426

  • Ich habe nun die Werte für den 16.9 editiert und den Gesamtwert von 9.1 auf 20.3 ausgebessert.


    Die Monatswerte und der Jahreswert wurden automatisch ausgebessert.


    In die Wertetabelle auf dem Stationsweb wurde der neue Wert nun ebenfalls übernommen. Nun stimmt der Wert auch tatsächlich mit der Summe der Stundenwerte überein. Das selbe gilt für die Grafik im Stationsweb.


    Fazit:

    Es kann passieren, das Awekas bei Stationsausfällen unrichtige Daten übernimmt. Deshalb die Tage, an denen eine Bresser Station ausfällt, genau die Summenwert kon6trollieren und notfalls editierem.