WSWIN-Bug in der Melderoutine

  • Problembeschreibung: Übertragung falscher (alter) Meßwerte


    Ist man in einer anderen Tagesansicht, als der aktuellen, kann es zu Falschmeldungen kommen! Deshalb zuvor die Datenaufzeichnung stoppen und erst dann in der Tagesansicht zurück blättern! Wie nachfolgend ausführlich beschrieben, treten diese Fehler auf:



    Aufzeichnung aktiv!.........Aufzeichnung gestoppt,
    ................................jetzt zurück blättern!


    1) bei Wetterlage über WSWIN melden:
    werden alle Daten des letzten auf der Grafik sichtbaren Datensatzes incl. Datum übertragen. Es kann also mitten im Sommer als Datum der 24.12. erscheinen,( sofern man diesen Tag ausgewählt hat) mit allen Werten vom Heiligen Abend. So sind auch plötzlich auftauchende absurde Temperaturwerte, Regenraten etc. miterklärlich. In der jeweiligen Tagesansicht wird immer der 23:55 Uhr Wert (da der letzte) übertragen, in der 24h-Ansicht der letzte sichtbare Datensatz ALLER Meßwerte. Das kann dann halt jede beliebige Uhrzeit sein.
    WICHTIG: Wenn die Wetterlage über WSWIN gemeldet wird, muß IMMER der aktuelle Tag in der Grafik sichtbar sein (egal, ob über Tages- oder 24h-Ansicht)!!!



    2) bei Melderoutine in einer anderen Tagesansicht:
    wie oben, nur ohne das jeweilige (falsche) Datum. Es wird immer das tatsächlich aktuelle Datum genommen, was eine Falschmeldung natürlich zusätzlich tarnt. Es werden die Regenmengen, Sonnenstunden, Windrichtung, Windgeschwindigkeit und Böen des gerade sichtbaren Tages übertragen. Nicht jedoch der Luftdruck, Temperatur und die Feuchte. Diese 3 Werte werden vom aktuellen Tag, letzter Wert übernommen - warum auch immer. Ich hab's mehrfach ausprobiert und kontrolliert. Es scheint allerdings auch hier Stationen/Konfigurationen zu geben, wo auch diese Werte falsch übermittelt werden.


    Die Ursache bei der Melderoutine ist folgende: normalerweise geht die WSWIN-Grafik bei neu einlaufenden Daten (Dateiüberwachung) IMMER in die aktuelle 24h-Ansicht, um den letzten Datensatz zu übertragen. Schlauerweise kann man jedoch die Melderoutine mit einem Offset um einige Minuten verzögern, weil die Daten nicht immer ganz pünktlich einlaufen, oder verarbeitet werden. Die meisten User geben deshalb 1 oder 2 Minuten-Offset als Meldeverzögerung ein. Wer zwischen der Datenaktualisierung und der Melderoutine auf einen anderen Tag zurückblättern, der hat Pech! Dann werden, wie oben beschrieben, diese gerade sichtbaren Datensätze geliefert. Und fertig ist der Salat!



    Offset Melderoutine


    Dieser Bug betrifft vor allem die Regenmengen, da diese sofort in der Karte auffallen. Je nach Meldeintervall bleiben also diese Falschmeldungen sichtbar. Wer alle 60 Minuten meldet, steht also bis zu 59 Minuten mit falschen Werten in den Karten. Sperrungen sind dann unvermeidlich! - Zudem bleiben die Daten gespeichert und werden zur Jahresregenmenge mit addiert, die dann fehlerhaft ist. Da wir demnächst noch eine Karte mit der aktuellen Jahresniederschlagsmenge einführen, sind hier Dauersperrungen (bis zur Berichtigung/Editierung) die unvermeidliche Folge.


    Der User weiß gar nicht warum er gesperrt wurde, weil in seiner WSWIN-Auswertung kein Fehler zu finden ist. Sehr wohl aber sind diese falschen Datensätze im „ws_debug_awekas.txt - Editor“ zu finden, sofern diese Aufzeichnung aktiviert wurde, was grundsätzlich empfehlenswert ist. Die Datensatzübertragung kann jeder User im WSWIN dann selber einsehen und bei der Fehlersuche aktiv mithelfen.



    debug-Einstellung............rot Regenmenge
    ..................................blau Regenrate



    Z.T. tritt dieser Bug auch NUR bei der Regenrate auf - ohne einen Tropfen Niederschlag zu melden.


    Was viele nicht wissen: WSWIN berechnet die Regenrate und sendet sie auch. Man kann sie sich zudem im WSWIN auch anzeigen lassen. Unter >Ansicht >Sensor Displayleiste >Zusatzsensoren >Regenmenge. Dann wird hier nicht die Regenmenge, sondern die Regenrate (rechts in der Leiste auf den Abb.) angezeigt. - Und je nach Ausleseintervall kann die Regenrate höher oder niedriger ausfallen.


    Getestet mit der aktuellen WSWIN-Version V2.97.10


    WICHTIG: Bitte probiert diesen Bug NICHT aus, sonst haben wir hier ein echtes Problem!!!!


    -------------------------


    Update 23.09.2014


    Mit der WSWIN-Version 2.97.12 ist dieser Bug definitv behoben. Wer ihn dennnoch produziert und bei uns dann diese Fehlmessungen meldet, hat eine veraltete Version! Bitte unbedingt das neue Upadte runterladen!

  • Servus,

    öffne ich WsWin, so erscheint unten links: Awekas: no current data. Also keine aktuellen Daten.

    Bei der letzten Aktualisierung, also Programmstart, lief alles noch einwandfrei.

    Verstehe nicht, was Awekas damit zu tun hat. WsWin bezieht seine Daten direkt von der Box (meteohub).

    Weiß jemand, was da los ist?


    Gruß Björn, Rohrmünz, ID11331