AWEKAS - Cómo configurar tu panel de instrumentos en una página web

    • Official Post

    Es posible insertar tu panel de instrumentos en una página web siempre y cuando esté activada la opción Awekas Plus


    El siguiente código es el que hay que configurar para ello


    Code
    http://www.awekas.at/premium/insert.php?id=XXXX&lg=d&eh=c&tz=0&header=1


    Los valores después de la ? son los que hay que configurar:


    XXXX = Id de estación Awekas (Tú ves este número en la URL cuando solicitas el panel de instrumentos en el mapa)
    lg=d / (lenguaje) d=Alemán, e=Inglés, n=Holandes, i=italiano, f=francés, es=Español
    eh=c / (Escala) c=Sistema métrico, f=Sistema americano
    tz=0 / (Diferencia horario con el servidor de Awekas) Esto es la diferencia horaria con el servidor Awekas (CET). En la Europa Central este valor es 0. Significa, no hay diferencia horaria con el servidor. Debe ser expresado en horas. Ejemplo, si tu diferencia horaria son 11 horas con respecto al CET, poner -11.
    header=1 (Mostrar hora y día) Si el valor es 1, la hora y fecha aparecerá en la cabecera del panel, si es 0, se ocultará esta información.


    Por favor, tener en cuenta que esta información es para uso privado, no comercial.


    Una forma sencilla de insertar el panel es con el uso de la función "iframe". Un ejemplo quedaría así:


    Code
    <iframe src="http://www.awekas.at/premium/insert.php?id=2&header=1" height="697" width="600" name="AWEKAS Instrumentenpanel"> 
    <p>Your browser cannot display iframes - please use the following link: <a href="http://www.awekas.at/premium/insert.php?id=2&lg=e&eh=c&tz=0&header=1">Instrumentenpanel</a></p> 
    </iframe>


    Saludos

  • Hola sierra norte.

    Ante todo gracias por su aportación. Hace ya algún tiempo pude colocar el código en mi blog meteorológico.


    El único problema que me surge es que, como podrá comprobar en el enlace de abajo, el termómetro de la dirección del viento no reconoce el carácter de la tilde de la u de "ÚLTIMO", y lo interpreta como código html " &uacute;" seguido de "ltimo. Se ve un poco feo además de confuso.


    Al cambiar el php de idioma, por ejemplo en inglés, no hay problema porque viene como "ACTUAL" y al no haber tildes no salta el código a la vista.


    He intentado todo cuanto está en mis conocimientos pero no consigo dar con alguna solución.
    Solo cabría que el webmaster de este lugar cambiara la palabra ÚLTIMO por ULTIMO (sin tilde) o ACTUAL y problema solucionado.

    ¿Usted sabría hacerle llegar mi mensaje?
    Muchísimas gracias!


    https://www.awekas.at/premium/…=es&eh=c&tz=0&header=0%22
    https://estacionpolitecnica.blogspot.com/

  • El único problema que me surge es que, como podrá comprobar en el enlace de abajo, el termómetro de la dirección del viento no reconoce el carácter de la tilde de la u de "ÚLTIMO", y lo interpreta como código html " &uacute;" seguido de "ltimo. Se ve un poco feo además de confuso.


    https://www.awekas.at/premium/…=es&eh=c&tz=0&header=0%22
    https://estacionpolitecnica.blogspot.com/

    Como me gusto la forma en la que tienes configurado el panel de instrumentos me he inspirado en el tuyo. Una autentica pena que no hay forma de resolverlo. No me importaria que las leyendas estuvieran en ingles, pero no se porque me hace la traduccion, cuando verdaderamente cuanto entras en la web de awekas se ve perfectamente.


    Y por lo que veo nadie te ha dado solucion.


    awekas.php


    Un saludo