Sendeausfälle NUR Richtung AWEKAS

  • Hallo Othi,

    in letzter Zeitr häufen sich bei mir Ausfälle (und lt. Murhy immer dann, wenn ich nicht zu Hause bin bzw mit AnyDesk nicht eingreifen kann) – aber nur Richtung AWEKAS:

    AWEKAS


    Andere Portale funktionieren jedoch ZUR SELBEN ZEIT DURCHGÄNGIG:

    awekas.at/board/index.php?attachment/4211/ Weathercloud


    Wettersektor


    Gestern hatte ich auch schon im WsWin-Forum genau deswegen Kontakt mit Tex (siehe link), heute gab es aber (ich war NATÜRLICH von 8:40 - ca.15:30 auswärts) schon wieder einen längeren Ausfall, und wieder nur AWEKAS. Die Verbindung WS-PC war nie unterbrochen. Das klingt für mich nach unglücklicher Komnbination

    • meine Einstellungen
    • WsWin und
    • AWEKAS.

    Meine Hard-/Software:

    • WS2800 mit HeavyWeather und WsWin per Dateiüberwachung.
    • Aufzeichnung alle 5min, senden zu AWEKAS alle 5min ohne Offset (zu den anderen Portalen alle 10min mit Offset).
    • Lenovo-Tablet mit Win10 Pro (Updates mit StopUpdates10 GESTOPPT – siehe link)
    • mit nur Win-eigener Firewall und WsWin natürlich ausgenommen
    • Internet: A1-Hybrid mit 2Mbit mit Kupferkabel + 40Mbit über Funk (600m entfernt, Direktsicht)

    Anbei noch Auszüge von (anonymisierten)

    • ws_debug_awekas.txt (betreffender Zeitraum)
    • ws_debug_www.txt (zum Vergleich)
    • WSWINERR.TXT (NUR AWEKAS has »failed«!)

    Vielleicht findest Du ja noch etwas (Protokolle AWEKAS-seitig …), was mir weiterhilft!

    lg und danke im Voraus

  • Hallo,


    also für gestern kann ich zumindest bei mir keinen Ausfall bestätigen.


    Bei mir war am 24.06. von 10:00 bis 12:00 und 13:00 bis 15:00 Uhr ein Ausfall vorhanden.

    Bei WsWin ist es ja so, dass bei 3maligen Fehlsenden, dann WSWIN eine Std. das Senden einstellt, und erst nach dieser Std. das Senden wieder aufnimmt.

    Viele Grüße, Best regards,
    Hans Josef - AWEKAS Admin
    AWEKAS sucht immer Wetter Administratoren
    AWEKAS est toujours à la recherche d'administrateurs météorologiques
    AWEKAS is always looking for weather administrators
    Für Supportanfragen geben sie bitte immer ihre Stationsbezeichnung und AWEKAS ID an!
    For each support request please add your station name and AWEKAS ID!
    my HP -->
    https://www.awekas.at/de/instrument.php?id=3587

  • Hallo Hans Josef, das mit dem 3maligen Fehlsenden (und Löschen des Zählers durch Drücken von »R«) ist mir bekannt.

    Ich kann mir folgende Szenarien vorstellen (Achtung – Spekulation!) :

    Es senden nicht alle 5-minütig, daher herrscht zu bestimmten Intervallen mehr »Meldestau« als zu anderen.

    • WsWin sendet bei mir zu den vollen 5min;
    • da kommen (manchmal) mehr als 3500 Meldungen fast gleichzeitig bei AWEKAS an;
    • ich stehe mit vielen anderen Meldungen in einer »Warteschlange« (da meine WS-Uhr derzeit ca. 4sec nachgeht wahrscheinlich ziemlich am Schluss);
    • AWEKAS arbeitet die Meldungen der Reihe nach ab und sendet nach erfolgetr Verarbeitung eine Meldung an mich zurück;
    • WsWin wartet eine mir unbekannte Zeit und stellt die Meldung dann auf OK (oder eben nicht);

    und/oder

    • AWEKAS hat eine »Begrenzung« der »Warteschlange« (zu viele Zugriffe zur gleichen Zeit);
    • ich bekomme daher (nur bei bestimmetn Zeiten) schon beim Sendeversuch ein »Connection Failed« (siehe WSWINERR.TXT) zur Antwort;
    • diejenigen, die Sekunden (-bruchteile) vorher senden merken natürlich nichts davon.

    Andere Portale haben (vermutlich) weniger sendende Mitglieder, bzw. eine »höher Begrenzung« der Zugriffsanzahl – wie gesagt: alles Spekulation.

    Da ist natürlich Othi als Programmierer von AWEKAS (»Warteschlenge« bzw. »maximale gleichzeitige Zugriffe») gefragt – oder auch Werner Krenn für WsWin (für die «maximal erlaubte Antwortzeit«, wenn's so was gibt).

    Ich werde jedenfalls mal meine WS-Uhr EINIGE sec VORSTELLEN (damit ich in der »Warteschlange« weiter vorne bin) – mal sehen, ob dann Ruhe ist.

  • Hatte ich auch -->

    Quote
  • Hallo


    Nachdem ich nun vom Urlaub zurück bin, kann ich mir das Problem genauer ansehen.

    Ich kann nicht ganz erklären warum Du einfach manchmal keine Verbindung zum Server erhältst. Der Eintrag "Awekas: waiting until 12 Uhr " stammt auf alle Fälle nicht von AWEKAS.

    WSWIN scheint nach dreimaligem Versuch für eine bestimmte Zeit das Senden einzustellen. (was eher kontraproduktiv ist - andere Wettersoftware versucht sogar nochmals zu senden... ). Werd deiesbezüglich mal Werner kontaktieren.

    Den Ausfall am 24.6. kann ich bestätigen. An diesem Tag habe ich Datenbankbereinigungen und Sicherungen durchgeführt.

    Auch heute wird es nochmals kurz zu Ausfällen kommen, da wir im Rechenzentrum noch Komponenten tauschen müssen.

  • Austausch der Komponenten ist vollzogen. Server waren von 12:04 bis 12:15 offline.

    PS: Es gibt (quasi) keine Warteschlange. Die Serverlast wird auf mehrere Server verteilt. Alle Server arbeiten weit unter der Kapazitätsgrenze und werden 24x7 überwacht.

    Hab mal eine Anfrage an Werner Krenn gesendet.

  • Danke erst mal, Othmar!

    Ich bin jetzt dort, wo Du warst (nämlich auf Urlaub – gerade in Almyros/Korfu eingetroffen), und was soll ich sagen: von 12:05 bis 14:00 wieder keine Verbindung


    anonymisierter Auszug aus ws_debug_awekas.txt (dank AnyDesk auch von Korfu aus möglich):

    2019-07-04 12:05:06.605 ?val=XXX;B59...;04.07.2019;12:00;22.0;50;1019.5;0.000;3.4;292;;;;de;0;9.4;;;;;;0.00;wswin_2.99.8

    2019-07-04 12:05:19.109 AWEKAS - no answer

    2019-07-04 12:05:19.109

    2019-07-04 12:10:06.611 ?val=CXXX;B59...;04.07.2019;12:05;22.1;51;1019.4;0.000;3.9;292;;;;de;0;9.4;;;;;;0.00;wswin_2.99.8

    2019-07-04 12:10:19.113 AWEKAS - no answer

    2019-07-04 12:10:19.113

    2019-07-04 12:15:06.610 ?val=XXX;B5...;04.07.2019;12:10;22.2;49;1019.3;0.000;4.4;292;;;;de;0;9.4;;;;;;0.00;wswin_2.99.8

    2019-07-04 12:15:19.120 AWEKAS - no answer

    2019-07-04 12:15:19.120

    2019-07-04 12:20:06.644 Awekas: waiting until 14 Uhr

    2019-07-04 12:25:06.631 Awekas: waiting until 14 Uhr

    2019-07-04 12:30:06.623 Awekas: waiting until 14 Uhr

    2019-07-04 12:35:06.634 Awekas: waiting until 14 Uhr

    2019-07-04 12:40:06.644 Awekas: waiting until 14 Uhr

    2019-07-04 12:45:06.685 Awekas: waiting until 14 Uhr

    2019-07-04 12:50:06.753 Awekas: waiting until 14 Uhr

    2019-07-04 12:55:06.742 Awekas: waiting until 14 Uhr

    2019-07-04 13:00:06.768 Awekas: waiting until 14 Uhr

    2019-07-04 13:05:06.761 Awekas: waiting until 14 Uhr

    2019-07-04 13:10:06.768 Awekas: waiting until 14 Uhr

    2019-07-04 13:15:06.760 Awekas: waiting until 14 Uhr

    2019-07-04 13:20:06.793 Awekas: waiting until 14 Uhr

    2019-07-04 13:25:06.776 Awekas: waiting until 14 Uhr

    2019-07-04 13:30:06.785 Awekas: waiting until 14 Uhr

    2019-07-04 13:35:06.820 Awekas: waiting until 14 Uhr

    2019-07-04 13:40:06.864 Awekas: waiting until 14 Uhr

    2019-07-04 13:45:06.858 Awekas: waiting until 14 Uhr

    2019-07-04 13:50:06.902 Awekas: waiting until 14 Uhr

    2019-07-04 13:55:06.897 Awekas: waiting until 14 Uhr

    2019-07-04 13:58:42.542 Awekas: waiting until 14 Uhr

    2019-07-04 14:00:06.644 ?val=XXX;B59...;04.07.2019;13:55;24.3;42;1018.6;0.000;5.2;202;;;;de;-1;9.4;;;;;;0.00;wswin_2.99.8

    2019-07-04 14:00:07.113 OK

    ... ab da funktioniert es wieder – MAL SEHEN (auch was von Werner da ev. kommt).


  • Ja weil wir im RZ heute wie geschrieben Komponenten tauschen mussten. Das war für WSWIN genau um 1 Minute zu lange. || Dann stellt WSWIN gleich wieder 3 Stunden den Betrieb ein. Wie schon geschrieben, andere Software probiert halt eine Minute später wieder. WSWIN vertschüsst sich gleich für 3 Stunden.

    Schaun ma mal was Werner sagt.

    Solche Abschaltungen kommen zwar ganz selten vor, aber sind leider nicht ganz auszuschließen. In letzter Zeit durch den Umzug auf die neue Hardware halt etwas mehr. Trotzdem sind wir derzeit bei einer Verfügbarkeit von 99,96% in den letzten 24h.

    8)

    Wünsch dir einen schönen Urlaub ;)

  • WSWIn schaltet den Sendebetrieb nach 3 Fehlversuchen (bei einem 5-Min Takt also nach 15 Minuten) nur für 2 Std. ab. WSWIN wartet 13 Sek. auf eine Antwort - erst dann wird es als Fehlermeldung gezählt. Es ist also nicht so, daß WSWIN sofort aussteigt. Das ist übrigens schon seit 2 Jahren so und zwar bei allen Wetterportalen.

    Der Grund: bei permaneneten Fehlermeldungen im Sendebetrieb (egal bei welchem Portal), hängt sich WSWIN irgendwann auf. WSWIN kann den Grund, warum ein Portal nicht erreichbar ist, nicht feststellen. Das kann am Wetterportal, an lokalen Rechnerbedingungen, oder auch am Internetprovider, etc. liegen. Da WSWIN es ermöglicht, Daten auch im 1-Minutenintervall zu erfassen und demzufolge auch in diesem Intervall "benutzerdefinierte Dateien" für die HP erstellen kann, können permanente Fehlermeldungen WSWIN dann lahmlegen - und dann geht eben gar nichts mehr - auch kein Sendebetrieb, da WSWIN auch keine neuen Daten mehr einliest. Also mußte WSWIN neu gestartet werden - was viel ärgerlicher war, als wenn WSWIN sicherheitshalber für die nächsten 2 Std. den Sendebetrieb (immer nur für das betroffen Wetterportal) einstellt und dafür am Laufen bleibt.

    Außerdem kann man diese Fehlermeldungen mittels des roten R-Buttons händisch löschen, dann sendet WSWIN wieder weiter, schaltet allerdings nach 3 erneuten Fehlversuchen wieder ab.

  • ... und heute morgen schon wieder:


    2019-07-05 08:30:08.063 ?val=ICH;B59...;05.07.2019;08:25;14.1;90;1018.2;0.000;0.0;45;;;;de;0;0.0;;;;;;0.00;wswin_2.99.8;13.136389;47.077222;10.5;11.5;14.1;8.8;16.2;30.9;-13.6;4.7;35.5;83.0;88.6;92.0;33.0;75.6;97.0;22.0;77.4;97.0;1017.6;1018.6;1018.6;1016.6;1019.0;1021.6;996.6;1018.7;1039.6;0.0;1.4;4.7;0.0;2.4;20.3;0.0;5.5;48.9;0.0;2.4;6.2;0.0;3.9;31.7;0.0;8.7;73.3;158.0;158;158;0.0;29.4;479.9;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

    2019-07-05 08:30:08.579 OK

    2019-07-05 08:35:08.055 ?val=ICH;B59....07.2019;08:30;14.3;90;1018.2;0.000;0.0;45;;;;de;0;0.0;;;;;;0.00;wswin_2.99.8;13.136389;47.077222;10.5;11.5;14.3;8.8;16.2;30.9;-13.6;4.7;35.5;83.0;88.6;92.0;33.0;75.6;97.0;22.0;77.4;97.0;1017.6;1018.6;1018.6;1016.6;1019.0;1021.6;996.6;1018.7;1039.6;0.0;1.4;4.7;0.0;2.4;20.3;0.0;5.5;48.9;0.0;2.4;6.2;0.0;3.9;31.7;0.0;8.7;73.3;158.0;158;158;0.0;29.4;479.9;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

    2019-07-05 08:35:08.578 OK

    2019-07-05 08:41:35.997 Awekas: waiting until 14 Uhr

    2019-07-05 08:45:06.856 Awekas: waiting until 14 Uhr

    2019-07-05 08:50:06.859 ?val=ICH;B59...;05.07.2019;08:45;14.9;87;1018.2;0.000;1.3;22;;;;de;0;3.1;;;;;;0.00;wswin_2.99.8

    2019-07-05 08:50:07.328 OK


    wobei auffällt, dass um 08:41 gleich »waiting until 14:00« kommt??? (das wären ganze 5h 21') @EDIT: 5h 19'

    Ich hab's zufälliger Weise zeitnah entdeckt und mit »R« deaktiviert.

  • Hallo Geri


    Ich habe von werner Krenn nun Rückmeldung erhalten. Laut Protokoll stellt sich die Frage was dein Rechner gestern um 8:40 gemacht hat. Da wäre das Senden fällig gewesen. Fehler ist aber erst um 08:41:35 gekommen.


  • ... weil mein Tablet JEDEN TAG um 08:40:00 (und um 20:40:00) automatisch neu startet – also auch die Tage davor und auch heute, seit ca. 7 Wochen. Deswegen erfolgte auch JEDEN TAG in AWEKAS die betreffende Meldung um 08:41 (bzw. 20:41). Das hat mit z-cron zu tun, das kann nur zu den vollen 5 min. Ganz vereinzelt kam zwischendurch ein »no answer«, aber eben immer nur jeweils einmalig.

    Mit dem Internet kanns nichts zu tun haben, da ich »doppelgleisig« mit A1-Hybrid fahre: 40MBit per Funk (600m Direktsicht) und 2MBit (per 7km Kupferkabel) und bei »heiklen« Downloads noch nie Probleme hatte (»zerschossene« rar, zip ... hatte ich noch nie).

    Das betreffende Protokoll für heute:

    2019-07-06 08:35:07.873 ?val=ICH;B59...;06.07.2019;08:30;11.6;88;1015.2;0.000;0.0;90;;;;de;-1;0.0;;;;;;0.00;wswin_2.99.8;13.136389;47.077222;10.8;11.8;13.7;8.8;16.6;30.9;-13.6;4.8;35.5;80.0;86.2;89.0;33.0;74.0;97.0;22.0;77.3;97.0;1015.6;1016.0;1016.6;1015.6;1018.4;1021.6;996.6;1018.7;1039.6;0.0;2.1;7.8;0.0;2.9;20.3;0.0;5.5;48.9;0.0;3.6;9.4;0.0;4.5;31.7;0.0;8.7;73.3;158.0;158;158;0.0;29.4;479.9;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

    2019-07-06 08:35:08.357 OK

    2019-07-06 08:41:36.631 ?val=ICH;B59...;06.07.2019;08:35;11.7;88;1015.6;0.000;0.0;90;;;;de;-1;0.0;;;;;;0.00;wswin_2.99.8

    2019-07-06 08:41:36.634 AWEKAS - no answer

    2019-07-06 08:41:36.635

    2019-07-06 08:45:06.892 ?val=ICH;B59...;06.07.2019;08:40;12.0;89;1015.3;0.000;0.0;68;;;;de;-1;0.0;;;;;;0.00;wswin_2.99.8

    2019-07-06 08:45:07.453 OK

    ... also um 08:41 »no answer«, aber um 08:45 OK – gestern aber:

    2019-07-05 08:35:08.578 OK

    2019-07-05 08:41:35.997 Awekas: waiting until 14 Uhr

    — warum SOFORT ein »waiting until 14 Uhr«!? Die Tage davor betraf es ja auch nicht die beiden Neustartzeiten (siehe Protokolle weiter oben), und außerdem wären es gestern ja 5h 19' gewesen (und nicht 2h).

    Ich will im WsWin-Forum nicht zweigleisig schreiben, Werner liest hier ja sicher mit. Außerdem ist mir das die nächsten 2 Wochen hier auf Korfu zu mühselig...

    Deswegen heute mal

    zusätzlich lg aus Acharavi

  • Quote

    Mit dem Internet kanns nichts zu tun haben...

    Für mich schon. Wenn WSWIN nach dem Neustart des PC sofort eine Datenmeldung absetzt, bevor die Internetverbindung aufgebaut ist, ist das WSWIN-Verhalten nachvollziehbar. Warum dann bis 14h Stillstand ist,....???? Scheint allerdings mit dieser Nummer zusammen zu hängen.


    Mögliche Abhilfe: Die Datenübermittlung um 1-2 Minute verzögern, dann ist die Internetverbindung auch aufgebaut.


  • Mögliche Abhilfe: Die Datenübermittlung um 1-2 Minute verzögern, dann ist die Internetverbindung auch aufgebaut.

    Habe ich schon probiert gehabt, dann habe ich aber so »krumme« Zeiten wie ..:36, ..:41, ..:46 (bzw. ..:37, ..:42, ..:47), Außerdem war das gestern das erste mal mit diesem Problem.

    Das Internet startet nämlich ca. 30 sec VOR WsWin und 40 sec VOR HeavyWeather (jeweils mit ReLaunch) – das habe ich damals beim Einrichten der Neustarts mitgemessen.

    καληνυχτα (Gute Nacht)

  • Καλησπέρα (Guten Abend),

    ich werde vorsichtshalber nach dem Urlaub zu Hause bei ReLaunch die Werte von WsWin und HeavyWeather um 10 - 20 sec weiter verzögern – zu viel ist aber nicht gut, da sich sonst HeavyWeather »verabschiedet« (MUSS ALS LETZTES starten, Wiederverbindung ist bei zu langer Dauer nur mit Hilfe der Bedieneinheit möglich).

    Χαιρετισμούς (Liebe Grüße) aus Acharavi

  • Zumindest um es testen würde ich die Datensendung wie oben beschrieben um 1 Minute verzögern. Bei der Wetterdatenübermittlung gibt es keine "krumme Zeiten". - im Gegenteil, es entlasten auch die AWEKAS-Server, wenn es etwas verteilter ist.

  • Es gibt genaus wenig "krumme Zeiten" wie "besonders nasssen Regen". Zeit ist Zeit. Und 18:52 ist eben nur 18:52 und nicht krumm.